Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Panthermail Student Login Issue
Incident Report for GSU Technology Systems
Resolved
IIT has resolved issues with Panthermail login. If you continue to experience issues, please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted Mar 26, 2019 - 11:07 EDT
Monitoring
IIT has applied a fix and will continue to monitor stability for 24 hours. If you continue to experience issues, please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted Mar 21, 2019 - 08:50 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of access issues for student email. More updates will be provided once available. If you have questions or concerns please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted Mar 21, 2019 - 07:36 EDT
This incident affected: PantherMail (Student Email).