Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Spectrum Services (PantherMart) Issues Reported
Incident Report for GSU Technology Systems
Resolved
Spectrum Services/PantherMart access has been restored. If you are still experiencing access issues with panthermart, then please email help@gsu.edu or contact IIT Service Desk by phone at 404-413-4357(HELP).
Posted Sep 27, 2016 - 12:14 EDT
Identified
Instructional Innovation and Technology (IIT) is currently investigating reports of issues with Spectrum Services/PantherMart. Additional information will be posted here when the issue is confirmed.
Posted Sep 27, 2016 - 11:32 EDT