Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Student Outlook Web Client Login Issues
Incident Report for GSU Technology Systems
Resolved
Instructional Innovation and Technology (IIT) has resolved issues with student logins to the Outlook web client. If you have questions or concerns, please contact the IIT Technology Service Desk at 404-413-4357 or email help@gsu.edu.
Posted 6 months ago. Apr 09, 2018 - 17:26 EDT
Monitoring
Instructional Innovation and Technology (IIT) has resolved issues with student logins to the Outlook web client We will continue to monitor behavior. If you have questions or concerns, please contact the IIT Technology Service Desk at 404-413-4357 or email help@gsu.edu.
Posted 6 months ago. Apr 09, 2018 - 14:50 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports that student logins to the Outlook web client is not working. We will continue to provide updates as they become available. If you have questions or concerns, please contact the IIT Technology Service Desk at 404-413-4357 or email help@gsu.edu.
Posted 6 months ago. Apr 09, 2018 - 14:18 EDT