Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Power Outage Sparks Hall 3rd Floor
Incident Report for GSU Technology Systems
Resolved
IIT has resolved issues reported about power on the third floor of Sparks Hall. If you continue to experience issues, please contact the IIT Technology Service Desk at 404-413-4357 (HELP) or email help@gsu.edu.
Posted Oct 18, 2017 - 09:50 EDT
Investigating
IIT is currently investigating reports of power loss in the ceiling of Sparks Hall affecting classrooms on the 3rd floor stemming from 320-330. Further updates will be posted as they become available.
Posted Oct 17, 2017 - 19:12 EDT