Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
GSU Website Issues Reported
Incident Report for GSU Technology Systems
Resolved
IIT has resolved issues reported with GSU websites. Please contact IIT Technology Service Desk to report any additional concerns at 404-413-4357(HELP) or email help@gsu.edu.
Posted 7 months ago. Apr 14, 2017 - 13:05 EDT
Investigating
Instructional Innovation and Technology (IIT) is currently investigating reports of issues with GSU Websites. Additional information will be posted here when the issue is confirmed.
Posted 7 months ago. Apr 14, 2017 - 12:03 EDT