Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Microsoft Outlook Web App (OWA) Issue
Incident Report for GSU Technology Systems
Resolved
Microsoft engineers have deployed a fix and confirmed the fix as a valid solution. Users should be able to access their mailbox via Outlook Web App(OWA). Please contact IS&T Help Center by phone 404-413-4357(Help) or email help@gsu.edu to report any additional problems.
Posted Nov 19, 2014 - 08:52 EST
Investigating
Microsoft is investigating the issue of some users experiencing intermittent failure when accessing their mailbox via Outlook Web App (OWA). Error message states "Something went wrong. Please try again later. If the problem continues, contact your helpdesk." At this time, we ask for those users to attempt to log on again and accessing your mailbox may be successful. Please continue to check here for any updates on when the issue has been resolved.
Posted Nov 14, 2014 - 16:01 EST