Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
GSU Website Issues Reported
Incident Report for GSU Technology Systems
Resolved
IIT resolved the issue reported with GSU websites. Please contact IIT Technology Service Desk at 404-413-4357(HELP) or email help@gsu.edu to report any additional issues.
Posted about 1 month ago. Oct 12, 2018 - 15:14 EDT
Update
Our teams will continue to monitor sites. Please report to IIT Technology Service Desk by phone at 404-413-4357(HELP) or email help@gsu.edu of any additional problems or concerns you may experience while accessing our GSU websites.
Posted 2 months ago. Sep 07, 2018 - 10:10 EDT
Update
The security check on all GSU websites have been removed. Our teams will continue to closely monitor the sites throughout the rest of the day. Please report to IIT Technology Service Desk by phone at 404-413-4357(HELP) or email help@gsu.edu of any additional problems or concerns you may experience while accessing our GSU websites.
Posted 4 months ago. Jul 30, 2018 - 07:42 EDT
Monitoring
The security check on all GSU websites have been removed. Our teams will continue to closely monitor the sites throughout the rest of the day. Please report to IIT Technology Service Desk by phone at 404-413-4357(HELP) or email help@gsu.edu of any additional problems or concerns you may experience while accessing our GSU websites.
Posted 4 months ago. Jul 26, 2018 - 08:11 EDT
Investigating
The investigation continues into GSU.edu sites. In order to maintain functionality and access to websites all users must complete the security check. This will be removed immediately after the issue is mitigated.
Posted 4 months ago. Jul 25, 2018 - 11:05 EDT
This incident affected: University Website.