Report an issue at: IIT Help Center, help@gsu.edu or call 404-413-HELP (4357)
Social Office Issues Reported
Incident Report for GSU Technology Systems
Resolved
IS&T has successfully resolved the social office issue. Please contact IS&T Help Center at help@gsu.edu or 404-413-4357(HELP) if there's any additional issue to report.
Posted Apr 03, 2014 - 12:17 EDT
Investigating
IS&T is currently investigating reports of issues with Social Office. At this time, users will not be able to access the social office website. Additional information will be posted here when the issue is confirmed.
Posted Apr 03, 2014 - 10:12 EDT